Out-of-Bounds Affecting tigervnc-server-module package, versions <0:1.8.0-1.32.amzn1


Severity

Recommended
medium

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
3.18% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-TIGERVNCSERVERMODULE-1707383
  • published27 Sept 2021
  • disclosed28 Feb 2017

Introduced: 28 Feb 2017

CVE-2016-10207  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 tigervnc-server-module to version 0:1.8.0-1.32.amzn1 or higher.
This issue was patched in ALAS-2017-879.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tigervnc-server-module package and not the tigervnc-server-module package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

The Xvnc server in TigerVNC allows remote attackers to cause a denial of service (invalid memory access and crash) by terminating a TLS handshake early.