Use After Free Affecting transmission-common package, versions <0:3.00-1.1.amzn1


Severity

Recommended
medium

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
2.7% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-TRANSMISSIONCOMMON-1723344
  • published27 Sept 2021
  • disclosed15 May 2020

Introduced: 15 May 2020

CVE-2018-10756  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 transmission-common to version 0:3.00-1.1.amzn1 or higher.
This issue was patched in ALAS-2020-1399.

NVD Description

Note: Versions mentioned in the description apply only to the upstream transmission-common package and not the transmission-common package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

Use-after-free in libtransmission/variant.c in Transmission before 3.00 allows remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via a crafted torrent file.

CVSS Base Scores

version 3.1