Out-of-bounds Write Affecting zsh-debuginfo package, versions <0:5.0.2-31.17.amzn1


Severity

Recommended
medium

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
0.53% (44th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-ZSHDEBUGINFO-1715400
  • published27 Sept 2021
  • disclosed11 Apr 2018

Introduced: 11 Apr 2018

CVE-2018-1100  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 zsh-debuginfo to version 0:5.0.2-31.17.amzn1 or higher.
This issue was patched in ALAS-2018-1107.

NVD Description

Note: Versions mentioned in the description apply only to the upstream zsh-debuginfo package and not the zsh-debuginfo package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

zsh through version 5.4.2 is vulnerable to a stack-based buffer overflow in the utils.c:checkmailpath function. A local attacker could exploit this to execute arbitrary code in the context of another user.

CVSS Base Scores

version 3.1