Out-of-Bounds Affecting zsh-html package, versions <0:5.0.2-31.17.amzn1


Severity

Recommended
medium

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
2.72% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-ZSHHTML-1715413
  • published27 Sept 2021
  • disclosed27 Feb 2018

Introduced: 27 Feb 2018

CVE-2014-10071  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 zsh-html to version 0:5.0.2-31.17.amzn1 or higher.
This issue was patched in ALAS-2018-1107.

NVD Description

Note: Versions mentioned in the description apply only to the upstream zsh-html package and not the zsh-html package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

In exec.c in zsh before 5.0.7, there is a buffer overflow for very long fds in the ">& fd" syntax.