Reachable Assertion Affecting dbus-common package, versions <1:1.12.28-1.amzn2023.0.1


Severity

Recommended
0.0
medium
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
1.51% (74th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN2023-DBUSCOMMON-5741445
  • published28 Jun 2023
  • disclosed8 Jun 2023

Introduced: 8 Jun 2023

CVE-2023-34969  (opens in a new tab)
CWE-617  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2023 dbus-common to version 1:1.12.28-1.amzn2023.0.1 or higher.
This issue was patched in ALAS2023-2023-213.

NVD Description

Note: Versions mentioned in the description apply only to the upstream dbus-common package and not the dbus-common package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2023 relevant fixed versions and status.

D-Bus before 1.15.6 sometimes allows unprivileged users to crash dbus-daemon. If a privileged user with control over the dbus-daemon is using the org.freedesktop.DBus.Monitoring interface to monitor message bus traffic, then an unprivileged user with the ability to connect to the same dbus-daemon can cause a dbus-daemon crash under some circumstances via an unreplyable message. When done on the well-known system bus, this is a denial-of-service vulnerability. The fixed versions are 1.12.28, 1.14.8, and 1.15.6.

CVSS Base Scores

version 3.1