Improper Certificate Validation Affecting java-27-amazon-corretto package, versions <1:27.0.1.0.10-1.amzn2023.1


Severity

Recommended
0.0
high
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
0.46% (40th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN2023-JAVA27AMAZONCORRETTO-21705463
  • published25 Oct 2026
  • disclosed20 Oct 2026

Introduced: 20 Oct 2026

NewCVE-2026-113470  (opens in a new tab)
CWE-295  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2023 java-27-amazon-corretto to version 1:27.0.1.0.10-1.amzn2023.1 or higher.
This issue was patched in ALAS2023-2026-3316.

NVD Description

Note: Versions mentioned in the description apply only to the upstream java-27-amazon-corretto package and not the java-27-amazon-corretto package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2023 relevant fixed versions and status.

Cryptographic issue in the Security Block-lists, Allow-lists, and other State component. This vulnerability was fixed in Firefox 158.0.1, Firefox ESR 153.5.1, Firefox ESR 115.43.1, Thunderbird 158.0.1, Thunderbird 153.5.1, and Firefox 158.0.2.

CVSS Base Scores

version 3.1