Improper Validation of Unsafe Equivalence in Input Affecting jsoup package, versions <0:1.23.2-1.amzn2023.0.1


Severity

Recommended
0.0
medium
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
0.3% (20th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN2023-JSOUP-19820198
  • published15 Sept 2026
  • disclosed6 Aug 2026

Introduced: 6 Aug 2026

CVE-2026-71497  (opens in a new tab)
CWE-1289  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2023 jsoup to version 0:1.23.2-1.amzn2023.0.1 or higher.
This issue was patched in ALAS2023-2026-2150.

NVD Description

Note: Versions mentioned in the description apply only to the upstream jsoup package and not the jsoup package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2023 relevant fixed versions and status.

jsoup is a Java library for working with real-world HTML. From 1.14.3 until 1.23.1, jsoup's HTML parser could incorrectly handle a malformed tag name ending in a control character, causing the tag to acquire the parsing behavior of a different element. When a custom Safelist permits certain raw-text elements, this misparsing can cause content that should remain inert text to be emitted as active markup after serialization, potentially resulting in cross-site scripting. jsoup's built-in Safelists are not affected. This issue is fixed in version 1.23.1.

CVSS Base Scores

version 3.1