Information Exposure Through Caching Affecting python3-flask package, versions <1:1.1.4-5.amzn2023.0.1


Severity

Recommended
0.0
medium
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
0.4% (35th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN2023-PYTHON3FLASK-15849009
  • published30 Mar 2026
  • disclosed21 Feb 2026

Introduced: 21 Feb 2026

CVE-2026-27205  (opens in a new tab)
CWE-524  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2023 python3-flask to version 1:1.1.4-5.amzn2023.0.1 or higher.
This issue was patched in ALAS2023-2026-1476.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python3-flask package and not the python3-flask package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2023 relevant fixed versions and status.

Flask is a web server gateway interface (WSGI) web application framework. In versions 3.1.2 and below, when the session object is accessed, Flask should set the Vary: Cookie header., resulting in a Use of Cache Containing Sensitive Information vulnerability. The logic instructs caches not to cache the response, as it may contain information specific to a logged in user. This is handled in most cases, but some forms of access such as the Python in operator were overlooked. The severity and risk depend on the application being hosted behind a caching proxy that doesn't ignore responses with cookies, not setting a Cache-Control header to mark pages as private or non-cacheable, and accessing the session in a way that only touches keys without reading values or mutating the session. The issue has been fixed in version 3.1.3.

CVSS Base Scores

version 3.1