Resource Exhaustion Affecting pyOpenSSL package, versions *


Severity

Recommended
0.0
low
0
10

Based on CentOS security rating.

Threat Intelligence

EPSS
1.9% (79th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CENTOS6-PYOPENSSL-1992867
  • published26 Jul 2021
  • disclosed29 Nov 2017

Introduced: 29 Nov 2017

CVE-2018-1000808  (opens in a new tab)
CWE-400  (opens in a new tab)

How to fix?

There is no fixed version for Centos:6 pyOpenSSL.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pyOpenSSL package and not the pyOpenSSL package as distributed by Centos. See How to fix? for Centos:6 relevant fixed versions and status.

Python Cryptographic Authority pyopenssl version Before 17.5.0 contains a CWE - 401 : Failure to Release Memory Before Removing Last Reference vulnerability in PKCS #12 Store that can result in Denial of service if memory runs low or is exhausted. This attack appear to be exploitable via Depends upon calling application, however it could be as simple as initiating a TLS connection. Anything that would cause the calling application to reload certificates from a PKCS #12 store.. This vulnerability appears to have been fixed in 17.5.0.