Buffer Overflow Affecting zsh-html package, versions <0:4.3.11-8.el6


Severity

Recommended
medium

Based on CentOS security rating.

Threat Intelligence

EPSS
0.53% (44th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CENTOS6-ZSHHTML-2153271
  • published26 Jul 2021
  • disclosed7 Apr 2018

Introduced: 7 Apr 2018

CVE-2018-1100  (opens in a new tab)
CWE-120  (opens in a new tab)

How to fix?

Upgrade Centos:6 zsh-html to version 0:4.3.11-8.el6 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream zsh-html package and not the zsh-html package as distributed by Centos. See How to fix? for Centos:6 relevant fixed versions and status.

zsh through version 5.4.2 is vulnerable to a stack-based buffer overflow in the utils.c:checkmailpath function. A local attacker could exploit this to execute arbitrary code in the context of another user.

CVSS Base Scores

version 3.1