Deserialization of Untrusted Data Affecting slf4j package, versions <0:1.7.4-4.el7_4


Severity

Recommended
0.0
high
0
10

Based on CentOS security rating.

Threat Intelligence

EPSS
14.7% (97th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CENTOS7-SLF4J-2099361
  • published26 Jul 2021
  • disclosed22 Feb 2018

Introduced: 22 Feb 2018

CVE-2018-8088  (opens in a new tab)
CWE-502  (opens in a new tab)

How to fix?

Upgrade Centos:7 slf4j to version 0:1.7.4-4.el7_4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream slf4j package and not the slf4j package as distributed by Centos. See How to fix? for Centos:7 relevant fixed versions and status.

org.slf4j.ext.EventData in the slf4j-ext module in QOS.CH SLF4J before 1.8.0-beta2 allows remote attackers to bypass intended access restrictions via crafted data. EventData in the slf4j-ext module in QOS.CH SLF4J, has been fixed in SLF4J versions 1.7.26 later and in the 2.0.x series.

References

CVSS Base Scores

version 3.1