Integer Overflow or Wraparound Affecting binutils package, versions *


0.0
medium

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
Expand this section
NVD
5.5 medium
Expand this section
Red Hat
5.3 medium
Expand this section
SUSE
3.3 low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-CENTOS8-BINUTILS-1938243
  • published 26 Jul 2021
  • disclosed 19 Dec 2018

How to fix?

There is no fixed version for Centos:8 binutils.

NVD Description

Note: Versions mentioned in the description apply only to the upstream binutils package and not the binutils package as distributed by Centos:8. See How to fix? for Centos:8 relevant fixed versions and status.

load_specific_debug_section in objdump.c in GNU Binutils through 2.31.1 contains an integer overflow vulnerability that can trigger a heap-based buffer overflow via a crafted section size.