Improper Input Validation Affecting binutils package, versions <0:2.30-108.el8


0.0
medium

Snyk CVSS

    Attack Complexity Low
    Availability High
Expand this section
NVD
6.5 medium
Expand this section
SUSE
5.5 medium
Expand this section
Red Hat
6.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-CENTOS8-BINUTILS-1966804
  • published 26 Jul 2021
  • disclosed 25 Nov 2020

How to fix?

Upgrade Centos:8 binutils to version 0:2.30-108.el8 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream binutils package and not the binutils package as distributed by Centos:8. See How to fix? for Centos:8 relevant fixed versions and status.

There's a flaw in the BFD library of binutils in versions before 2.36. An attacker who supplies a crafted file to an application linked with BFD, and using the DWARF functionality, could cause an impact to system availability by way of excessive memory consumption.