Improper Authentication Affecting curl package, versions <0:7.61.1-22.el8_6.3


medium

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
Expand this section
NVD
8.1 high
Expand this section
SUSE
5.3 medium
Expand this section
Red Hat
8.1 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-CENTOS8-CURL-2804201
  • published 27 Apr 2022
  • disclosed 27 Apr 2022

How to fix?

Upgrade Centos:8 curl to version 0:7.61.1-22.el8_6.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream curl package and not the curl package as distributed by Centos:8. See How to fix? for Centos:8 relevant fixed versions and status.

An improper authentication vulnerability exists in curl 7.33.0 to and including 7.82.0 which might allow reuse OAUTH2-authenticated connections without properly making sure that the connection was authenticated with the same credentials as set for this transfer. This affects SASL-enabled protocols: SMPTP(S), IMAP(S), POP3(S) and LDAP(S) (openldap only).