Improper Enforcement of Message Integrity During Transmission in a Communication Channel Affecting curl package, versions <0:7.61.1-22.el8_6.4


0.0
medium

Snyk CVSS

    Attack Complexity High
    User Interaction Required
    Integrity High
Expand this section
NVD
5.9 medium
Expand this section
Red Hat
5.3 medium
Expand this section
SUSE
6.6 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-CENTOS8-CURL-2936525
  • published 28 Jun 2022
  • disclosed 27 Jun 2022

How to fix?

Upgrade Centos:8 curl to version 0:7.61.1-22.el8_6.4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream curl package and not the curl package as distributed by Centos:8. See How to fix? for Centos:8 relevant fixed versions and status.

When curl < 7.84.0 does FTP transfers secured by krb5, it handles message verification failures wrongly. This flaw makes it possible for a Man-In-The-Middle attack to go unnoticed and even allows it to inject data to the client.