Resource Exhaustion Affecting dbus-tools package, versions <1:1.12.8-23.el8_7.1


0.0
medium

Snyk CVSS

    Attack Complexity Low
    Availability High
Expand this section
NVD
6.5 medium
Expand this section
Red Hat
6.5 medium
Expand this section
SUSE
4.4 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-CENTOS8-DBUSTOOLS-3047092
  • published 14 Oct 2022
  • disclosed 5 Oct 2022

How to fix?

Upgrade Centos:8 dbus-tools to version 1:1.12.8-23.el8_7.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream dbus-tools package and not the dbus-tools package as distributed by Centos:8. See How to fix? for Centos:8 relevant fixed versions and status.

An issue was discovered in D-Bus before 1.12.24, 1.13.x and 1.14.x before 1.14.4, and 1.15.x before 1.15.2. An authenticated attacker can cause dbus-daemon and other programs that use libdbus to crash by sending a message with attached file descriptors in an unexpected format.