Incorrect Behavior Order: Early Validation Affecting gzip package, versions <0:1.9-13.el8_5


0.0
high

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
8.8 high
Expand this section
Red Hat
8.8 high
Expand this section
SUSE
8.4 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-CENTOS8-GZIP-2445554
  • published 9 Apr 2022
  • disclosed 7 Apr 2022

How to fix?

Upgrade Centos:8 gzip to version 0:1.9-13.el8_5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gzip package and not the gzip package as distributed by Centos:8. See How to fix? for Centos:8 relevant fixed versions and status.

An arbitrary file write vulnerability was found in GNU gzip's zgrep utility. When zgrep is applied on the attacker's chosen file name (for example, a crafted file name), this can overwrite an attacker's content to an arbitrary attacker-selected file. This flaw occurs due to insufficient validation when processing filenames with two or more newlines where selected content and the target file names are embedded in crafted multi-line file names. This flaw allows a remote, low privileged attacker to force zgrep to write arbitrary files on the system.