Cross-site Scripting (XSS) Affecting ipa-healthcheck package, versions <0:0.4-6.module+el8.3.0+7710+e2408ce4


Severity

Recommended
0.0
medium
0
10

Based on CentOS security rating.

Threat Intelligence

EPSS
29.73% (99th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CENTOS8-IPAHEALTHCHECK-2081052
  • published26 Jul 2021
  • disclosed27 Jun 2015

Introduced: 27 Jun 2015

CVE-2015-9251  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Centos:8 ipa-healthcheck to version 0:0.4-6.module+el8.3.0+7710+e2408ce4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ipa-healthcheck package and not the ipa-healthcheck package as distributed by Centos. See How to fix? for Centos:8 relevant fixed versions and status.

jQuery before 3.0.0 is vulnerable to Cross-site Scripting (XSS) attacks when a cross-domain Ajax request is performed without the dataType option, causing text/javascript responses to be executed.

References