Cleartext Transmission of Sensitive Information Affecting libcurl-minimal package, versions <0:7.61.1-18.el8_4.2


medium

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
Expand this section
NVD
7.5 high
Expand this section
SUSE
5.9 medium
Expand this section
Red Hat
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-CENTOS8-LIBCURLMINIMAL-2124477
  • published 15 Sep 2021
  • disclosed 15 Sep 2021

How to fix?

Upgrade Centos:8 libcurl-minimal to version 0:7.61.1-18.el8_4.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libcurl-minimal package and not the libcurl-minimal package as distributed by Centos:8. See How to fix? for Centos:8 relevant fixed versions and status.

A user can tell curl >= 7.20.0 and <= 7.78.0 to require a successful upgrade to TLS when speaking to an IMAP, POP3 or FTP server (--ssl-reqd on the command line orCURLOPT_USE_SSL set to CURLUSESSL_CONTROL or CURLUSESSL_ALL withlibcurl). This requirement could be bypassed if the server would return a properly crafted but perfectly legitimate response.This flaw would then make curl silently continue its operations withoutTLS contrary to the instructions and expectations, exposing possibly sensitive data in clear text over the network.