Use After Free Affecting libxml2 package, versions <0:2.9.7-9.el8_4.2


medium

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
7.8 high
Expand this section
SUSE
5.9 medium
Expand this section
Red Hat
7.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-CENTOS8-LIBXML2-2111872
  • published 26 Jul 2021
  • disclosed 21 Apr 2021

How to fix?

Upgrade Centos:8 libxml2 to version 0:2.9.7-9.el8_4.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libxml2 package and not the libxml2 package as distributed by Centos:8. See How to fix? for Centos:8 relevant fixed versions and status.

There's a flaw in libxml2's xmllint in versions before 2.9.11. An attacker who is able to submit a crafted file to be processed by xmllint could trigger a use-after-free. The greatest impact of this flaw is to confidentiality, integrity, and availability.