NULL Pointer Dereference Affecting libxml2 package, versions <0:2.9.7-9.el8_4.2


medium

Snyk CVSS

    Attack Complexity Low
    Availability High
Expand this section
NVD
5.9 medium
Expand this section
SUSE
7.5 high
Expand this section
Red Hat
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-CENTOS8-LIBXML2-2112072
  • published 26 Jul 2021
  • disclosed 1 May 2021

How to fix?

Upgrade Centos:8 libxml2 to version 0:2.9.7-9.el8_4.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libxml2 package and not the libxml2 package as distributed by Centos:8. See How to fix? for Centos:8 relevant fixed versions and status.

A vulnerability found in libxml2 in versions before 2.9.11 shows that it did not propagate errors while parsing XML mixed content, causing a NULL dereference. If an untrusted XML document was parsed in recovery mode and post-validated, the flaw could be used to crash the application. The highest threat from this vulnerability is to system availability.