Authentication Bypass by Primary Weakness Affecting mod_auth_mellon package, versions <0:0.14.0-3.el8_0.2


Severity

Recommended
0.0
high
0
10

Based on CentOS security rating.

Threat Intelligence

EPSS
2.97% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CENTOS8-MODAUTHMELLON-1978132
  • published26 Jul 2021
  • disclosed10 May 2018

Introduced: 10 May 2018

CVE-2019-3878  (opens in a new tab)
CWE-305  (opens in a new tab)

How to fix?

Upgrade Centos:8 mod_auth_mellon to version 0:0.14.0-3.el8_0.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mod_auth_mellon package and not the mod_auth_mellon package as distributed by Centos. See How to fix? for Centos:8 relevant fixed versions and status.

A vulnerability was found in mod_auth_mellon before v0.14.2. If Apache is configured as a reverse proxy and mod_auth_mellon is configured to only let through authenticated users (with the require valid-user directive), adding special HTTP headers that are normally used to start the special SAML ECP (non-browser based) can be used to bypass authentication.