Out-of-bounds Read Affecting pcre2 package, versions <0:10.32-3.el8_6


medium

Snyk CVSS

    Attack Complexity Low
    Availability High
Expand this section
NVD
9.1 critical
Expand this section
SUSE
8.6 high
Expand this section
Red Hat
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-CENTOS8-PCRE2-2808600
  • published 5 May 2022
  • disclosed 23 Mar 2022

How to fix?

Upgrade Centos:8 pcre2 to version 0:10.32-3.el8_6 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pcre2 package and not the pcre2 package as distributed by Centos:8. See How to fix? for Centos:8 relevant fixed versions and status.

An out-of-bounds read vulnerability was discovered in the PCRE2 library in the compile_xclass_matchingpath() function of the pcre2_jit_compile.c file. This involves a unicode property matching issue in JIT-compiled regular expressions. The issue occurs because the character was not fully read in case-less matching within JIT.