Resource Exhaustion The advisory has been revoked - it doesn't affect any version of package pipewire  (opens in a new tab)


Threat Intelligence

EPSS
4.99% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CENTOS8-PIPEWIRE-2069951
  • published26 Jul 2021
  • disclosed2 Mar 2020

Introduced: 2 Mar 2020

CVE-2020-10018  (opens in a new tab)
CWE-400  (opens in a new tab)

Amendment

The Centos security team deemed this advisory irrelevant for Centos:8.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pipewire package and not the pipewire package as distributed by Centos.

WebKitGTK through 2.26.4 and WPE WebKit through 2.26.4 (which are the versions right before 2.28.0) contains a memory corruption issue (use-after-free) that may lead to arbitrary code execution. This issue has been fixed in 2.28.0 with improved memory handling.