Open Redirect Affecting platform-python package, versions *


medium

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Scope Changed
    Confidentiality High
Expand this section
NVD
7.4 high
Expand this section
Red Hat
7.4 high
Expand this section
SUSE
7.4 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-CENTOS8-PLATFORMPYTHON-2988860
  • published 23 Aug 2022
  • disclosed 22 Aug 2022

How to fix?

There is no fixed version for Centos:8 platform-python.

NVD Description

Note: Versions mentioned in the description apply only to the upstream platform-python package and not the platform-python package as distributed by Centos:8. See How to fix? for Centos:8 relevant fixed versions and status.

** DISPUTED ** Python 3.x through 3.10 has an open redirection vulnerability in lib/http/server.py due to no protection against multiple (/) at the beginning of URI path which may leads to information disclosure. NOTE: this is disputed by a third party because the http.server.html documentation page states "Warning: http.server is not recommended for production. It only implements basic security checks."