Improper Verification of Cryptographic Signature Affecting python3-libdnf package, versions <0:0.63.0-3.el8


0.0
medium

Snyk CVSS

    Attack Complexity High
    Privileges Required High
    User Interaction Required
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
7.5 high
Expand this section
Red Hat
6.4 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-CENTOS8-PYTHON3LIBDNF-2147886
  • published 26 Jul 2021
  • disclosed 16 Mar 2021

How to fix?

Upgrade Centos:8 python3-libdnf to version 0:0.63.0-3.el8 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python3-libdnf package and not the python3-libdnf package as distributed by Centos:8. See How to fix? for Centos:8 relevant fixed versions and status.

A flaw was found in libdnf's signature verification functionality in versions before 0.60.1. This flaw allows an attacker to achieve code execution if they can alter the header information of an RPM package and then trick a user or system into installing it. The highest risk of this vulnerability is to confidentiality, integrity, as well as system availability.