Resource Exhaustion Affecting python3-libs package, versions <0:3.6.8-39.el8_4


0.0
medium

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Availability High
Expand this section
NVD
6.5 medium
Expand this section
SUSE
4 medium
Expand this section
Red Hat
6.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-CENTOS8-PYTHON3LIBS-1968741
  • published 1 Sep 2021
  • disclosed 10 Aug 2021

How to fix?

Upgrade Centos:8 python3-libs to version 0:3.6.8-39.el8_4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python3-libs package and not the python3-libs package as distributed by Centos:8. See How to fix? for Centos:8 relevant fixed versions and status.

There's a flaw in urllib's AbstractBasicAuthHandler class. An attacker who controls a malicious HTTP server that an HTTP client (such as web browser) connects to, could trigger a Regular Expression Denial of Service (ReDOS) during an authentication request with a specially crafted payload that is sent by the server to the client. The greatest threat that this flaw poses is to application availability.