Information Exposure Affecting python3-libs package, versions <0:3.6.8-41.el8


0.0
medium

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
Expand this section
NVD
5.7 medium
Expand this section
SUSE
5.5 medium
Expand this section
Red Hat
5.7 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-CENTOS8-PYTHON3LIBS-2147472
  • published 26 Jul 2021
  • disclosed 10 Mar 2021

How to fix?

Upgrade Centos:8 python3-libs to version 0:3.6.8-41.el8 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python3-libs package and not the python3-libs package as distributed by Centos:8. See How to fix? for Centos:8 relevant fixed versions and status.

There's a flaw in Python 3's pydoc. A local or adjacent attacker who discovers or is able to convince another local or adjacent user to start a pydoc server could access the server and use it to disclose sensitive information belonging to the other user that they would not normally be able to access. The highest risk of this flaw is to data confidentiality. This flaw affects Python versions before 3.8.9, Python versions before 3.9.3 and Python versions before 3.10.0a7.