Insufficient Verification of Data Authenticity Affecting rpm-libs package, versions <0:4.14.3-14.el8_4


0.0
medium

Snyk CVSS

    Attack Complexity High
    User Interaction Required
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
7 high
Expand this section
Red Hat
6.7 medium
Expand this section
SUSE
3.3 low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-CENTOS8-RPMLIBS-2112283
  • published 26 Jul 2021
  • disclosed 11 Mar 2021

How to fix?

Upgrade Centos:8 rpm-libs to version 0:4.14.3-14.el8_4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rpm-libs package and not the rpm-libs package as distributed by Centos:8. See How to fix? for Centos:8 relevant fixed versions and status.

A flaw was found in RPM's signature check functionality when reading a package file. This flaw allows an attacker who can convince a victim to install a seemingly verifiable package, whose signature header was modified, to cause RPM database corruption and execute code. The highest threat from this vulnerability is to data integrity, confidentiality, and system availability.