Incorrect Implementation of Authentication Algorithm Affecting tomcat-docs-webapp package, versions <1:9.0.120-1.el8_10


Severity

Recommended
high

Based on CentOS security rating.

Threat Intelligence

EPSS
0.72% (52nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CENTOS8-TOMCATDOCSWEBAPP-20162889
  • published27 Sept 2026
  • disclosed9 Apr 2026

Introduced: 9 Apr 2026

CVE-2026-29145  (opens in a new tab)
CWE-303  (opens in a new tab)

How to fix?

Upgrade Centos:8 tomcat-docs-webapp to version 1:9.0.120-1.el8_10 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tomcat-docs-webapp package and not the tomcat-docs-webapp package as distributed by Centos. See How to fix? for Centos:8 relevant fixed versions and status.

CLIENT_CERT authentication does not fail as expected for some scenarios when soft fail is disabled vulnerability in Apache Tomcat, Apache Tomcat Native.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.1.0-M7 through 10.1.52, from 9.0.83 through 9.0.115; Apache Tomcat Native: from 1.1.23 through 1.1.34, from 1.2.0 through 1.2.39, from 1.3.0 through 1.3.6, from 2.0.0 through 2.0.13.

Users are recommended to upgrade to version Tomcat Native 1.3.7 or 2.0.14 and Tomcat 11.0.20, 10.1.53 and 9.0.116, which fix the issue.

CVSS Base Scores

version 3.1