Out-of-Bounds Affecting zlib package, versions <0:1.2.11-18.el8_5


0.0
high

Snyk CVSS

    Attack Complexity Low
    Availability High
Expand this section
NVD
7.5 high
Expand this section
Red Hat
8.2 high
Expand this section
SUSE
8.1 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-CENTOS8-ZLIB-2434351
  • published 28 Mar 2022
  • disclosed 20 Apr 2018

How to fix?

Upgrade Centos:8 zlib to version 0:1.2.11-18.el8_5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream zlib package and not the zlib package as distributed by Centos:8. See How to fix? for Centos:8 relevant fixed versions and status.

zlib before 1.2.12 allows memory corruption when deflating (i.e., when compressing) if the input has many distant matches.