CVE-2026-42504 Affecting authentik-fips-2025.12 package, versions <2025.12.6-r2


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.56% (43rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-AUTHENTIKFIPS202512-17431537
  • published23 Jun 2026
  • disclosed2 Jun 2026

Introduced: 2 Jun 2026

CVE-2026-42504  (opens in a new tab)

How to fix?

Upgrade Chainguard authentik-fips-2025.12 to version 2025.12.6-r2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream authentik-fips-2025.12 package and not the authentik-fips-2025.12 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

Decoding a maliciously-crafted MIME header containing many invalid encoded-words can consume excessive CPU.

CVSS Base Scores

version 3.1