Reachable Assertion Affecting avahi package, versions <0.9_rc4-r0


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.2% (11th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-AVAHI-16077262
  • published16 Apr 2026
  • disclosed3 Apr 2026

Introduced: 3 Apr 2026

CVE-2026-34933  (opens in a new tab)
CWE-617  (opens in a new tab)

How to fix?

Upgrade Chainguard avahi to version 0.9_rc4-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream avahi package and not the avahi package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

Avahi is a system which facilitates service discovery on a local network via the mDNS/DNS-SD protocol suite. Prior to version 0.9-rc4, any unprivileged local user can crash avahi-daemon by sending a single D-Bus method call with conflicting publish flags. This issue has been patched in version 0.9-rc4.

CVSS Base Scores

version 3.1