Improper Input Validation Affecting azure-functions-extension-bundles-4 package, versions <4.36.0-r1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.51% (41st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-AZUREFUNCTIONSEXTENSIONBUNDLES4-17445250
  • published24 Jun 2026
  • disclosed22 Jun 2026

Introduced: 22 Jun 2026

CVE-2026-48109  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Chainguard azure-functions-extension-bundles-4 to version 4.36.0-r1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream azure-functions-extension-bundles-4 package and not the azure-functions-extension-bundles-4 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

MessagePack for C# is a MessagePack serializer for C#. Prior to 2.5.301 and 3.1.7, A vulnerability exists in the optional LZ4 decompression path used by MessagePack compression modes Lz4Block and Lz4BlockArray. The decoder implementation is based on a deprecated fast-decompression algorithm that does not take a source-length bound. A remote attacker can send a crafted MessagePack payload with manipulated LZ4 token/length fields to force out-of-bounds reads from the compressed input buffer. In affected environments, this can trigger an AccessViolationException during decompression, causing process termination (denial of service). Under some conditions, limited unintended memory disclosure from over-read data may also be possible before failure. This vulnerability is fixed in 2.5.301 and 3.1.7.