Direct Request ('Forced Browsing') Affecting cluster-autoscaler-1.35 package, versions <1.35.0-r1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.83% (58th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-CLUSTERAUTOSCALER135-15564775
  • published14 Mar 2026
  • disclosed6 Mar 2026

Introduced: 6 Mar 2026

CVE-2026-25679  (opens in a new tab)
CWE-425  (opens in a new tab)

How to fix?

Upgrade Chainguard cluster-autoscaler-1.35 to version 1.35.0-r1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cluster-autoscaler-1.35 package and not the cluster-autoscaler-1.35 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

url.Parse insufficiently validated the host/authority component and accepted some invalid URLs.

References

CVSS Base Scores

version 3.1