Cross-site Scripting (XSS) Affecting commercial-gitlab-rails-ee-19.2 package, versions <19.2.7-r4


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.3% (20th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-COMMERCIALGITLABRAILSEE192-20825125
  • published11 Oct 2026
  • disclosed12 Aug 2026

Introduced: 12 Aug 2026

CVE-2026-73490  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Chainguard commercial-gitlab-rails-ee-19.2 to version 19.2.7-r4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream commercial-gitlab-rails-ee-19.2 package and not the commercial-gitlab-rails-ee-19.2 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

Loofah is a general library for manipulating and transforming HTML/XML documents and fragments, built on top of Nokogiri. Prior to 2.25.2, Loofah's HTML5 sanitizer applies its local-reference restriction only to the xlink:href attribute on SVG use and feImage elements, while browsers also accept the plain href attribute. A crafted sanitized SVG can therefore reference an arbitrary same-origin external document; use may render external SVG content containing scripts or other dangerous content, and feImage may load external images for tracking. Applications that sanitize user-supplied SVG with Loofah's default allowlist are affected. This issue is fixed in version 2.25.2.

CVSS Base Scores

version 3.1