Improper Encoding or Escaping of Output Affecting coredns-1.13 package, versions <1.13.2-r5


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.37% (31st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-COREDNS113-17253508
  • published9 Jun 2026
  • disclosed7 May 2026

Introduced: 7 May 2026

CVE-2026-39826  (opens in a new tab)
CWE-116  (opens in a new tab)

How to fix?

Upgrade Chainguard coredns-1.13 to version 1.13.2-r5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream coredns-1.13 package and not the coredns-1.13 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

If a trusted template author were to write a <script> tag containing an empty 'type' attribute or a 'type' attribute with an ASCII whitespace, the execution of the template would incorrectly escape any data passed into the <script> block.

CVSS Base Scores

version 3.1