Resource Exhaustion Affecting elastic-connectors-fips-9.5 package, versions <9.5.4-r5


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.6% (49th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-ELASTICCONNECTORSFIPS95-21751395
  • published27 Oct 2026
  • disclosed22 Oct 2026

Introduced: 22 Oct 2026

NewCVE-2026-75507  (opens in a new tab)
CWE-400  (opens in a new tab)
CWE-407  (opens in a new tab)

How to fix?

Upgrade Chainguard elastic-connectors-fips-9.5 to version 9.5.4-r5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream elastic-connectors-fips-9.5 package and not the elastic-connectors-fips-9.5 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

GraphQL-core is a Python port of the GraphQL.js reference implementation. From 3.0.0 until 3.2.12 and 3.3.0rc1, the OverlappingFieldsCanBeMerged rule in specified_rules repeatedly compares fields that share response names and recursively re-compares flattened inline fragments during the validation phase. The prior named-fragment memoization does not cover this path, so nested repeated inline fragments can drive quadratic and worst-case O(n²·m²) CPU work before any resolver or AST-based depth or complexity control runs. An unauthenticated remote attacker can submit a shallow, highly compressible GraphQL query that pins a worker process and can saturate a multi-worker service. This issue is fixed in versions 3.2.12 and 3.3.0rc1.