HTTP Request Smuggling The advisory has been revoked - it doesn't affect any version of package envoy  (opens in a new tab)


Threat Intelligence

EPSS
0.87% (54th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-ENVOY-5846444
  • published21 Aug 2023
  • disclosed4 Apr 2023

Introduced: 4 Apr 2023

CVE-2023-27491  (opens in a new tab)
CWE-444  (opens in a new tab)

Amendment

The Chainguard security team deemed this advisory irrelevant for Chainguard:latest.

NVD Description

Note: Versions mentioned in the description apply only to the upstream envoy package and not the envoy package as distributed by Chainguard.

Envoy is an open source edge and service proxy designed for cloud-native applications. Compliant HTTP/1 service should reject malformed request lines. Prior to versions 1.26.0, 1.25.3, 1.24.4, 1.23.6, and 1.22.9, There is a possibility that non compliant HTTP/1 service may allow malformed requests, potentially leading to a bypass of security policies. This issue is fixed in versions 1.26.0, 1.25.3, 1.24.4, 1.23.6, and 1.22.9.