CVE-2025-59731 Affecting ffmpeg-fips-7.1 package, versions <7.1.2-r0


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.18% (8th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-FFMPEGFIPS71-21460724
  • published23 Oct 2026
  • disclosed6 Oct 2025

Introduced: 6 Oct 2025

CVE-2025-59731  (opens in a new tab)

How to fix?

Upgrade Chainguard ffmpeg-fips-7.1 to version 7.1.2-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ffmpeg-fips-7.1 package and not the ffmpeg-fips-7.1 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

When decoding an OpenEXR file that uses DWAA or DWAB compression, the specified raw length of run-length-encoded data is not checked when using it to calculate the output data.

We read rle_raw_size from the input file at [0], we decompress and decode into the buffer td->rle_raw_data of size rle_raw_size at [1], and then at [2] we will access entries in this buffer up to (td->xsize - 1) * (td->ysize - 1) + rle_raw_size / 2, which may exceed rle_raw_size.

We recommend upgrading to version 8.0 or beyond.