CVE-2026-33815 Affecting gitaly-18.11 package, versions <18.11.6-r1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.61% (49th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-GITALY1811-17528683
  • published26 Jun 2026
  • disclosed7 Apr 2026

Introduced: 7 Apr 2026

CVE-2026-33815  (opens in a new tab)

How to fix?

Upgrade Chainguard gitaly-18.11 to version 18.11.6-r1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gitaly-18.11 package and not the gitaly-18.11 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

Memory-safety vulnerability in github.com/jackc/pgx/v5.

CVSS Base Scores

version 3.1