Resource Exhaustion The advisory has been revoked - it doesn't affect any version of package gitlab-rails-ce-18.4  (opens in a new tab)


Threat Intelligence

EPSS
0.57% (45th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-GITLABRAILSCE184-14887270
  • published7 Jan 2026
  • disclosed25 Sept 2025

Introduced: 25 Sep 2025

CVE-2025-59830  (opens in a new tab)
CWE-400  (opens in a new tab)
CWE-770  (opens in a new tab)

Amendment

The Chainguard security team deemed this advisory irrelevant for Chainguard:latest.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gitlab-rails-ce-18.4 package and not the gitlab-rails-ce-18.4 package as distributed by Chainguard.

Rack is a modular Ruby web server interface. Prior to version 2.2.18, Rack::QueryParser enforces its params_limit only for parameters separated by &, while still splitting on both & and ;. As a result, attackers could use ; separators to bypass the parameter count limit and submit more parameters than intended. Applications or middleware that directly invoke Rack::QueryParser with its default configuration (no explicit delimiter) could be exposed to increased CPU and memory consumption. This can be abused as a limited denial-of-service vector. This issue has been patched in version 2.2.18.