Cross-site Scripting (XSS) Affecting gitlab-rails-ce-19.5 package, versions <19.5.1-r1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.56% (47th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-GITLABRAILSCE195-21663402
  • published23 Oct 2026
  • disclosed20 Oct 2026

Introduced: 20 Oct 2026

NewCVE-2026-112945  (opens in a new tab)
CWE-80  (opens in a new tab)

How to fix?

Upgrade Chainguard gitlab-rails-ce-19.5 to version 19.5.1-r1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gitlab-rails-ce-19.5 package and not the gitlab-rails-ce-19.5 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

Vite is a frontend tooling framework for JavaScript. Prior to 6.4.4, 7.3.7, 8.1.6, 8.2.4, and 8.3.3, applications using custom middleware are vulnerable when they pass an unchanged browser request URL to server.transformIndexHtml. getHtmlFilename uses the query-bearing request URL to resolve an existing local file while preserving attacker-supplied leading slashes in the generated proxy module URL. If the transformed HTML contains an inline module script and a victim browser loads the crafted development-server page, the leading double slash makes the browser fetch and execute an attacker-controlled module in the Vite-served page. This execution can expose sensitive page data or permit critical actions available to the affected application. This issue is fixed in versions 6.4.4, 7.3.7, 8.1.6, 8.2.4, and 8.3.3.

CVSS Base Scores

version 3.1