Improper Verification of Cryptographic Signature The advisory has been revoked - it doesn't affect any version of package gitlab-rails-ee-fips-17.1  (opens in a new tab)


Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
10.68% (96th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-GITLABRAILSEEFIPS171-8022787
  • published17 Sept 2024
  • disclosed10 Sept 2024

Introduced: 10 Sep 2024

CVE-2024-45409  (opens in a new tab)
CWE-347  (opens in a new tab)

Amendment

The Chainguard security team deemed this advisory irrelevant for Chainguard:latest.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gitlab-rails-ee-fips-17.1 package and not the gitlab-rails-ee-fips-17.1 package as distributed by Chainguard.

The Ruby SAML library is for implementing the client side of a SAML authorization. Ruby-SAML in <= 12.2 and 1.13.0 <= 1.16.0 does not properly verify the signature of the SAML Response. An unauthenticated attacker with access to any signed saml document (by the IdP) can thus forge a SAML Response/Assertion with arbitrary contents. This would allow the attacker to log in as arbitrary user within the vulnerable system. This vulnerability is fixed in 1.17.0 and 1.12.3.