Link Following Affecting gomplate-fips-4 package, versions <4.3.3-r23


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.36% (27th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-GOMPLATEFIPS4-18598084
  • published9 Aug 2026
  • disclosed7 Aug 2026

Introduced: 7 Aug 2026

CVE-2026-71556  (opens in a new tab)
CWE-59  (opens in a new tab)

How to fix?

Upgrade Chainguard gomplate-fips-4 to version 4.3.3-r23 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gomplate-fips-4 package and not the gomplate-fips-4 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

go-git is an extensible git implementation library written in pure Go. Prior to 5.19.2 and 6.0.0-alpha.5, worktree operations (including checkout, status, and add) resolve symbolic links inside the working tree without confining resolution to the worktree boundary, so a maliciously crafted repository containing a symlink can cause go-git to read from or write to files outside the intended working directory when the repository is cloned and its worktree operations are used. Versions 5.19.2 and 6.0.0-alpha.5.

CVSS Base Scores

version 3.1