CVE-2026-21721 Affecting grafana-11.5 package, versions <11.5.10-r2


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.72% (54th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-GRAFANA115-15351623
  • published25 Feb 2026
  • disclosed27 Jan 2026

Introduced: 27 Jan 2026

CVE-2026-21721  (opens in a new tab)

How to fix?

Upgrade Chainguard grafana-11.5 to version 11.5.10-r2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream grafana-11.5 package and not the grafana-11.5 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

The dashboard permissions API does not verify the target dashboard scope and only checks the dashboards.permissions:* action. As a result, a user who has permission management rights on one dashboard can read and modify permissions on other dashboards. This is an organization‑internal privilege escalation.

CVSS Base Scores

version 3.1