Improper Authentication Affecting grafana-12.4 package, versions <12.4.3.02-r0


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.23% (14th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-GRAFANA124-17091235
  • published29 May 2026
  • disclosed13 May 2026

Introduced: 13 May 2026

CVE-2026-33377  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

Upgrade Chainguard grafana-12.4 to version 12.4.3.02-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream grafana-12.4 package and not the grafana-12.4 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

An Editor can overwrite a dashboard not owned by them to acquire admin on that specific dashboard. The user must have write access to the dashboard to escalate privilege.

CVSS Base Scores

version 3.1