Direct Request ('Forced Browsing') Affecting http-echo package, versions <1.0.0-r23


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.83% (58th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-HTTPECHO-15724779
  • published21 Mar 2026
  • disclosed6 Mar 2026

Introduced: 6 Mar 2026

CVE-2026-25679  (opens in a new tab)
CWE-425  (opens in a new tab)

How to fix?

Upgrade Chainguard http-echo to version 1.0.0-r23 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream http-echo package and not the http-echo package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

url.Parse insufficiently validated the host/authority component and accepted some invalid URLs.

References

CVSS Base Scores

version 3.1