CVE-2026-56851 Affecting ingress-nginx-controller-1.15 package, versions <1.15.11-r0


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.47% (41st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-INGRESSNGINXCONTROLLER115-21717100
  • published26 Oct 2026
  • disclosed7 Oct 2026

Introduced: 7 Oct 2026

NewCVE-2026-56851  (opens in a new tab)

How to fix?

Upgrade Chainguard ingress-nginx-controller-1.15 to version 1.15.11-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ingress-nginx-controller-1.15 package and not the ingress-nginx-controller-1.15 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

The Nickname profile can panic with an out-of-bounds slice error when transforming crafted input into a short destination buffer.

CVSS Base Scores

version 3.1