Improper Privilege Management Affecting k3s-fips-1.34 package, versions <1.34.12.1-r3


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.11% (2nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-K3SFIPS134-21723445
  • published27 Oct 2026
  • disclosed12 Oct 2026

Introduced: 12 Oct 2026

NewCVE-2026-95837  (opens in a new tab)
CWE-269  (opens in a new tab)

How to fix?

Upgrade Chainguard k3s-fips-1.34 to version 1.34.12.1-r3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream k3s-fips-1.34 package and not the k3s-fips-1.34 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

containerd is an open-source container runtime. From 2.1.0 until 2.2.7 and 2.3.4, containerd's CRI CreateContainer checkpoint restore is vulnerable because CRIU restores process security state from checkpoint data instead of enforcing the destination ContainerConfig. An attacker who can create a container from a crafted checkpoint can supply restored credentials, capabilities, no_new_privs, and seccomp state. The restored process can run as root with full capabilities and no enforced seccomp filters while CRI status reports the requested configuration. Systems that do not use CRI checkpoint restore are not affected. This issue is fixed in versions 2.2.7 and 2.3.4.

CVSS Base Scores

version 3.1